Steepster Bug Status Thread

320 Replies

For some reason an occasional tea page looks odd and won’t let me post tasting notes? One example is David’s Coffee Cake here:

But I’m not sure if the page will look odd to anyone else.

This just happened to me with Swiss Mountain from Della Terra. The page looks long like there’s just one column of things and whenever I try to post a tasting note, it boots me back to the sign in page as if I don’t have an account.

yep, that’s what i’m getting. Thanks for describing it better.

Jason admin said

What seems to be happening is that some of the pages (ie. the tea page) have a mobile version that is powered by google and shown to people who hit the page when coming from google on mobile. However, it looks like sometimes that mobile version is being cached and shown to non-mobile users. We cleared the cache so it should be working now, but let me know if you see others like this.

Yeah, I’m definitely not using mobile. The David’s Coffee Cake page looks normal to me now. Thanks as usual, Jason!

Found another one with the weird caching issue:

This tea page is stuck in mobile-mode for me:

Jason admin said

Looks like the cache was broken and they’re displaying correctly now. Unfortunately, I don’t have much control over the cache at the moment.

Tabby said

This one is also broken: EDIT: Thank you so much, Cameron B!

If you click the “Edit” link and then save without making any changes, it fixes the issue.

Kittenna said

Cameron B – you’re a genius! I just fixed Tea Desire’s Tiger Town this way :)

@Kittenna – I saw someone else mention the fix somewhere, so I can’t take credit! ;)

It’s on this very thread, on this very page in fact. Just scroll down a little further to the post started by Roswell Strange that says "Hey Jason,

Don’t know if there’s anything you can do at all but these two have been stuck in that weird mobile mode for coming up on two weeks now and it’s driving me insane…"

Login or sign up to post a message.

Dustin said

I’ve been noticing for several months now that when I look under discussions, there will be numerous threads that had been started years ago that show a recent update on the discussion page as though someone replied to it a few days ago, but the last post I can find on these threads is from years ago. As far as I can tell, there has been no recent activity on them. It’s strange!

It happens when spam accounts post on the thread and then a moderator deletes the spam account. Their message history disappears, but the thread stays ‘bumped’.

Jason admin said

Yea, that should be what’s causing it. I’ll add it to the list.

Login or sign up to post a message.

Leafhopper said

Has anyone else had trouble accessing Steepster today? It was completely down for me this morning, and now, while everything mainly works again, I can’t get to my dashboard by clicking my name. The issue seems to be a slash.

This link doesn’t work:

But this one does:

Yeah, I was getting a 404 message today. No Steepster pages were working at all. Hopefully all issues have been resolved now.

Jason admin said

Sorry, there was an updated on Amazon Web Services that caused some issues. It should be resolved now. Let us know if you’re not able to access any pages.

Login or sign up to post a message.

Hey Jason,

Don’t know if there’s anything you can do at all but these two have been stuck in that weird mobile mode for coming up on two weeks now and it’s driving me insane:

These two are still stuck… Three weeks now…

The Tourbillon one isn’t cached on my end, though the Lime Jello Salad one is.

If these tea pages are going to be stuck in this mobile cache view for so long and there is nothing we can do but “wait,” is there absolutely no way that these pages can at least be made so that the “Review This Tea”, “Add to Cupboard” and “Add to Wishlist” links don’t act like our accounts are logged out so we can’t use the page, but instead keep us logged in so we can keep using the mobile-cached tea pages? Cause this waiting game on some of these mobile-cached tea pages just to be able to leave reviews or add the teas into our cupboards/wishlists is getting brutal…

What drives me really crazy, is that if it’s supposed to be some whole ‘mobile view’ issue shouldn’t I at least be able to add them to my cupboard if I’m on my phone!? Except, same issue when using my phone – formatting looks weird and when I click any of the buttons you mentioned it jumps me to the Steepster main page or whatever…

So irritating. I just want to add them to my cupboard…

Hmm.. I don’t know any of this tech stuff but I am only accessing steepster on a laptop and some of the cached pages do the same thing (sends me back to Steepster’s main page). I don’t know how caching works, but if no one can do anything on the page for the tea, then how does it uncache?

What you are using to access the site doesn’t have anything to do with it as far as I’m aware (I don’t even own a cellphone or mobile device, only a desktop PC; yes, last human alive without a cell, I’m aware). I don’t know how the pages get stuck in that view, but last time I asked if there was some way the cache could be “refreshed” on a few tea pages I was waiting on (just up above on this thread) I was told by Jason “I don’t have much control over the cache at the moment” — which I took to mean, “You’ll have to just keep waiting until the problem fixes itself.” And I have no idea what causes a new version of the page to end up in the cache. But this is a real problem if these pages are unusable to us for what can be weeks or even months, because the “Review This Tea”, “Add to Cupboard” and “Add to Wishlist” links on the mobile-cache tea pages act like we aren’t logged in and just loop you to a “logged out” instance of the front page, so you can’t review the tea, add it to your cupboard, or add it to your wishlist as long as the page is in that state. I’ve had reviews saved on a Notepad .txt file for weeks waiting on tea pages to recache themselves because I couldn’t add reviews to them because of this bug. It’s getting really annoying. If those mobile-cached pages at least used links that registered our logged-in status so we could still use their functionality and review the teas from them or add them to our cupboards/wishlists (despite the tea page looking weird while being in that mode) then it wouldn’t be so awful to deal with.

Arby is an angel woman!!! Apparently if you click “edit” on the mobile cached page it doesn’t bounce you back to the login page, and then if you hit save from the edit screen it resets the page to the normal view!

I tried this out with both of the two teas that have been stuck for me the last three weeks and it worked for both of them!

Awesome, I just tried doing this with Jelly + Ice Cream and it worked on the laptop! Thanks for sharing how to do this, Arby and Roswell. :D

I’m honestly shocked the Edit link didn’t have the same “logged out” problem! Thanks for the tip, I’ll keep that in mind so I don’t have reviews sitting around saved on my Notepad file for weeks on end waiting for the tea pages to recache themselves before I can post them!

Jason admin said

Wow, I had no idea that worked. I guess it makes sense because it must be clearing the cache (didn’t realize that was happening). I super glad to hear that there is at least a temp fix available to you guys.

Otherwise, Mike is going to see if he can figure out what is causing the overall problem and maybe he can prevent it from coming up in the first place, or at least make it less frequent.

Login or sign up to post a message.

teevogel said

When I added this , it was created as just “Schoko”, though I was able to change it to its proper full name right after. Apparently tea names aren’t handled the same way during creation and editing?

What do you mean by not handled the same way? Personally I haven’t noticed a difference between adding a new tea and editing an existing one.

teevogel said

The “&” in the middle of the tea name was accepted when I edited it, but not when I created it.

Jason admin said

Hmm, let me know if you see that again. It’s possible that the unique characters could create issues. I thought that was fixed a long time ago but it could have came up again.

Login or sign up to post a message.

I don’t think I’ve been getting e-mail notifications for any replies for any of my posts in the forum?

But I do still get e-mail notifications for replies on my tasting notes.

Jason admin said

Are any of the email notification settings different in your account?

Under e-mail settings, I don’t see any option for notifications regarding the forums? I did get a notification for THIS thread, but possibly I’m getting notifications for older threads but not for recently created threads that I’ve replied in?

Jason admin said

Oh yea, notifications for discussions are managed on the individual threads themselves. Maybe check the thread you’re expecting to receive notifications on and see if you’re still subscribed?

Oh that might be the problem then.. no problem. I will check that for future threads. Thanks Jason!

Login or sign up to post a message.

Bunnieh said

Didn’t want to reply to an older comment, but Fruits D’Alsace is stuck in the unusable mode and clicking Edit isn’t resolving the issue.

(was able to access page on mobile, log out, log back in and then save tasting note…)

Jason admin said

Does it still look messed up to you? It looks correct for me.

Login or sign up to post a message.

Ok. Really don’t know where else to put this.

On Adagio Tea White Symphony page, the page looks off to me. Also, if I try to either add it to my cupboard or add a tasting note, It takes me back to the main login page. Not sure what this means, but I would like to add a tasting note to that tea and it won’t let me.

I fixed it for you. If you see a tea page like this, you can just click “Edit” and then save without any changes, and it’ll go back to normal. It’s some kind of strange issue where tea pages get stuck in mobile mode.

I’m not sure where to look for this “Edit” option. I have another tea page (Adagio Berry Blast) which is like this and I’ve tried clicking “Edit Tea Info” and it just reloads the page the same way. Please let me know what I am doing wrong.

Are you making sure you are saving after you ‘edit tea info’ even if you aren’t adding any new tea info?

That’s the thing. It won’t even let me enter “Edit” mode. It just kicks me back to the same page. There is no option to edit info and nowhere to save edited info. Maybe because I’m such a new member I don’t have editing privileges yet??

Hi Shanie, how long have you had your profile for? New members don’t have the capability to edit tea pages until they’ve had their account for over a month – I believe the editing capability was restricted by the admin team for new accounts several years ago as a response to spammers occasionally changing the listings of highly reviewed or popular teas to spam messages.

I’m sure if you let someone know what tea you’re having issues with we can fix it for you :)

OH okay. It must have been because you’re a new member. It looks like Dustin fixed it for you. If you have any more you need fixed, just post them here and someone will do it for you. :D
Edited to add: which is essentially what Roswell just said. Whoops

Login or sign up to post a message.

I get it. I’m a noobie so I am restricted. That’s fine. I can deal. I’m just glad that I’ve got a few followers already and people seem to be really nice and helpful for my noob problems and questions. Now, if only there were some way to get rid of the spammers.

Login or sign up to post a message.

Hey Jason, is there anything we can do about getting new flavors added? There are a few that I’m always unhappy are missing… :(

Jason admin said

Unfortunately, I don’t have any easy solution available currently. I’ve been tracking all of the suggestions, just don’t have a way to update the database. I’ll have to check with mike to see what he can do…

Okay, no problem if it’s a big deal.

Login or sign up to post a message.

Login or sign up to leave a comment.