A discovery about the Explore page, and a question.

Whenever I have visited the Explore page, other than the text, “Right now on Steepster … A live stream of the latest activity from the Steepster Universe.” in the grey region in the center of the page, it has been blank.

I think, purely by accident, I stayed on that page for a few minutes only to discover that there was a live stream of information being displayed. But it seems it takes a least a minute before anything starts showing up.

Is that just my experience, or is that the way it is for the rest of you?

16 Replies
K S said

That’s how I first noticed the button at the bottom of the page – I got tired of waiting.

Ah, so you have to wait too, then? Is it about 90 seconds (as it is for me)?

If so, then I think it would be helpful to make it clear—-on that page or somewhere else pertinent like in the upcoming FAQ—-that you need to wait X number of seconds before things start to show up. It IS very cool to be able to view everything going on in the “Steepster Universe”!

Login or sign up to post a message.

Jason admin said

Yea…the page has gotten pretty slow. That’s not by design, it’s just overall slowness caused by such large volumes of data being stored and transfered by the system. When working properly, it shouldn’t take more than a couple seconds. In good news, we’re planning to do some much needed cleaning/bug fixing coming up soon, so hopefully we’ll get a chance to speed up the explore page as well as the rest of the site.

Sounds great. Thank you Jason for that update! : )

ssajami said

Thank you Jason, for the update. The site does need some speeding up. That said, I also want to mention that I think this site is AWESOME – from the site design to the community it contains.

Angrboda said

YAY! I’m looking forward to that.

SimplyJenW said

I know of at least one Steepster regular that is having trouble getting Steepster to load at all on her computer. Do you have an estimate when the upgrades will begin?

Login or sign up to post a message.

Uniquity said

I’ve only had that feed actually load for me once – and I loved it – But I never figured out how I made it happen. : )

Login or sign up to post a message.

I use Firefox as my browser, and actually have never seen that page load up… It gives me something to look forward too!

I also use Firefox (I switched from IE a few months ago, and I like Firefox better) on my PC running Windows and my DSL is r e a l l y s l o w , yet I am able to view the livestream (although sometimes it takes as long as four minutes before I actually see anything).

I’ve had issues with Firefox blocking images from certain sites (although I don’t know that the livefeed objects are actually ‘images’), and so I have to find out the source by right clicking, selecting Page Source Info, then selecting the Media tab, and scrolling through the list to find the site that is hosting the images, then copying it. And then I manually tell Firefox to allow images from that site to display through ToolsOptions → Load Images automatically << check-box >> → Exceptions << button >>, and then I add the address of the site to the list and select Allow << button >>.

I don’t know, just a shot in the dark. : )

Still no joy on getting the “Explore” page to load, but thanks for the detailed steps to try. I use the http://assets.steepster.com/ as the source, but that may be wrong as well… i just don’t have the knowledge or desire to spend all my time getting other’s web pages to work on my browser. I may miss content, but figure it saves me a good deal of frustration! :)

Login or sign up to post a message.

kanata said

Thanks for posting this. I thought that it was just something to do with my browser not loading an image or feed right so I’ve always just ended up using the links at the bottom.

Login or sign up to post a message.

DaisyChubb said

I let mine load for about 20 minutes and it worked! haha so I think it’s just a waiting issue sometimes

Sometimes it takes as many as 20 minutes for mine to load, too. It seems to be very inconsistent. Because sometimes it loads in as little as a minute.

I am also noticing that, sometimes, most pages on Steepster will not respond at all for reasonably long periods of time for me (i.e. when I select any of the tabs at the top of the page, any discussion thread, account info pages, etc). When this is happening I can go to any other web page—-in another tab—-in my browser (Firefox) and they load without even a hiccup. Closing that tab, creating a new one, and attempting to reload the Steepster web page doesn’t even seem to make a difference (nor does closing and restarting the browser). So it must be something with Steepster. Is anyone else having this issue?

My guess is that their server must be overloaded, or something. I am hoping that the speeding up they will be doing, as Jason mentioned above, will have a dramatic impact on this. I really appreciate all they are doing for us. I look forward to participating and reading what others are posting. And yet with the slowdowns happening more and more I am starting to get a little discouraged when it comes to making choices to see what’s going on out here.

The interesting thing is, even when I can’t get anything else in Steepster to load, the Select tab will respond—-and so load that page—-immediately (http://member.ly/steepster-select). This is very interesting. My guess is that that web page is being supported by another server (esp. since it has a different domain name: member.ly).

For now, I’ll just take it as it comes. : )

DaisyChubb said

Yep, memberly is a different website altogether so it wouldn’t be related to the Steepster problems.

I sometimes have the same latency/loading issues, but they usually solve themselves after I take a website break and come back

Login or sign up to post a message.

I just recently noticed that the live stream loads and displays IMMEDIATELY now (at least for me it does). I haven’t noticed yet, but I am hoping the other latency issues are resolved too.

Thank you Jason, and the tech powers that be!

Login or sign up to post a message.

Login or sign up to leave a comment.