Unable to add a new tea...

I did report this to the guys…but…here is what I emailed them!
They’ve fixed the other issues we’ve been having, too!

Hi again! Sorry to keep bothering you! LOL :)
I have been trying to add a new Upton Tea for the past hour and I put everything in as usual and it ‘times out’ or this…

Someone forgot to turn off the kettle. Check back later or try one of these:

Go back to the previous page Drop us a note
6 Replies

Ok…I actually added it but didn’t insert a description or picture and it seemed to work – just a heads up!

I just added a new tea and the description works fine but the picture won’t load. :( Not sure if yours worked earlier?

Login or sign up to post a message.

Ricky admin said

Seems to be working now :D

Let us know if there are any more problems.

I just tried to add a new tea and it said there is already a tea with that name. So I typed the name into the search bar and nothing came up. Also pictures are still not working :( Now I can’t post at all.

Login or sign up to post a message.

I have 64 new notices and I can see them. I emailed the Steepster-Gurus about it :(

Login or sign up to post a message.

Lee select said

Having this trouble today. Emailed Steepster.

Login or sign up to post a message.

Login or sign up to leave a comment.