Jason admin said

Steepster Bug Status Thread

last edited 3/14/17

Below you’ll find a listing of non-trivial bug statuses so it is clearer what issues have been communicated to us (Steepster) and what the current status is on fixing them. Unfortunately, it will likely take us a while to get to many of them, but hopefully this will at least give you confidence that we’re aware of an issue.

FYI – Please know that even though issues are listed here, it doesn’t mean the site is unusuable or unstable. Any obviously critical issues we can determine affect all users are dealt with asap. This is mostly for reported issues that affected an undertermined amount of users, or issues that are not “critical” in nature.

Next to the issues is the status. It’s super helpful to get any and all information about the situaiton in which you encounter an issue (browser, OS, time, content, etc) so that we can recreate it ourselves, which helps us understand the root cause and address the issue. Once we’ve addressed an issue we’ll remove it from the list. Check below for a key as to what each status means.

If you have any other issues feel free to post below with any information you have about it or email me directly (jason at steepster.com). As always, thanks for any and all patience you can manage while we work through issues :)

Issues

Resolved
- New activity not loading under the “Notices” tab of the dashboard

Confirmed
- Tasting Notes not sorted in correct order on tea page
- Search algorithm for relevancy needs to be updated
- Quotes in tea name showing HTML entity
- Tasting notes not displayed on company page if previous note exists
- Some tea images no longer working
- CSS not loading on various pages
- Quotes not being escaped form tea form fields

Acknowledged
- Multiple users not receiving email notifications for site activity
- Tasting Notes Not Saving
- Previously posted tasting notes can’t be found anymore
- Password reset not working
- Messages sent to/received by the wrong users
- “logged N times” link from user’s Tea Ratings page does not go to tasting note

Reported
- Teas previously added to wishlist no longer on wishlist
- Content of tasting note duplicated within tasting note, unable to edit

*If you’re unable to comment or post in the discussion section, it might be because you have a URL with invalid formatting in your account bio section. Delete the link or change it to correct formatting (including the full “http://”) to restore the ability to comment.

Key

Reported: Bug has been brought to our attention, but we don’t have enough information to determine if it is a site issue affecting multiple users. More information needed.

Acknowledged: Bug has been reported and evidence has been submitted for us to conclude it is likely a site issue (not specific to the user). We have attempted to recreate/debug the issue, but we have not yet be able to recreate. More information needed.

Confirmed: Bug is acknowledged and recreated by us. No further info needed.

Resolved: Issue has been confirmed and a fix has been deployed. The issue should no longer be present. After a period of being listed as “Resolved”, issues will be removed from this thread.

241 Replies
looseTman said

Jason,
This new thread is excellent! It should expedite solutions & help inspire confidence that Steepster is a reliable forum for tea lovers, bloggers, & suppliers. Well done!! Thank you!

Jason admin said

Thanks!

mrmopar said

+1 thanks Jason!

pico-bags said

Really nice forum for tea lover.

Wow. Thanks so much for this thread! It’s good to know my favorite community of people is being taken care of.

cookies said

In addition to reviews disappearing, it seems that sometimes parts of reviews are somehow deleted. It happened to me here http://steepster.com/teas/the-finest-brew/55133-wuliang-shan-2014-spring-puer-mini-tuo and when I tried to edit the review to add in the deleted section, the edits wouldn’t take. I mentioned it in chat and apparently it has happened to other people as well.

Jason admin said

Hmm, I’ve had a report that was related to the use of a “>” sign and everything after that being removed. Could it be anything like that? Were there any non-alphanumeric characters in the tasting note?

I’ll add to the list above.

cookies said

Nope, nothing like that.

Jason admin said

Weird. So is it that you had seen it submitted properly, but then later you came back and it was gone? Or did it just never show the full content that you had submitted?

cookies said

Yes, it submitted fine. The next day I went to respond to a comment and noticed a large chunk of the first paragraph was missing.

Jason admin said

Hmm, interesting. Thanks for the info!

Cupboard sorting is working! :) (Well, at least for me that is… I hope it is for everyone)

Jason admin said

Yep, Mike fixed that over the holidays.

Jason admin said

Anyone else seen the issue where part of their tasting note is deleted/not saved after using a < symbol? If so, can you send me a link to the tasting note along with the exact content you originally submitted?

kysmet4e said

Yes. It happened in the past. It’s OK for me now ;)

In your original post, can you add “Resolved” to the key? That is, if a problem has been fixed (like what Mike did over the holidays with the cupboard sorting), it would be great to have the status moved from “Confirmed” to “Resolved”. Then we know it’s not a problem anymore.

looseTman said

Great idea – A way to celebrate each success!

It will also reinforce that Steepster is committed to being a reliable forum for tea lovers.

Jason admin said

Sure thing. I originally didn’t want to have that because I didn’t want to have a bunch of old bugs listed that are no longer an issue. But I’ll note something as resolved once it’s fixed, then remove it after it’s been listed for a while.

I sent a message to somebody three days ago, but when I received a response to it, it was from someone else entirely. So, I’m not sure I know what happened, but I’m pretty certain I tried to send a message from the other person’s page. I can’t actually say for certain, because I don’t remember. I just wanted to see if anybody else was having problems with messages going through.

Jason admin said

Was the message you received back in response to your message, or was it just a different, unrelated message? I’ve heard some people mention issues of mail going to the wrong people, but I’ve also heard people make the mistake of sending it to the wrong person.

I’ll add it to the list, but could use more info if you or anyone else has any.

Yeah. I feel bad because I generally am careful about how I send my messages, but I don’t spend enough time to actually remember everything I did afterward. But the message I received was in response. The old message was there too. If anybody else has had this happen, then perhaps it would help for you to know. I don’t message people enough to really say that it was a technical issue, though.

Jason admin said

No worries, I understand. If you assume it’s working fine you’re not going to try to remember everything that happened :). Well at least you saw your previous response so the message stayed threaded and wasn’t split in the middle. That’s helpful to know.

Uniquity said

If you look in the sent part of your inbox does it show going to the right person? Just curious. I sent one to 52Teas once years ago accidentally because that was at the top of the list.

looseTman said

Jason & Mike,

Thanks for fixing all the sorting functions on the Teaware pages.

Kudos to you both!

Jason admin said

You’re welcome. Glad that we can finally get some of those pesky errors cleared out. I’ll post more about the update tomorrow, but looks pretty good so far. We’ve seen that email notifications aren’t being sent, so Mike’s working on that now. If you see anything, let me know.

Jason admin said

Email notifications should be back now.

Dexter said

Since the update tonight all the main discussion threads are showing as unread. If I open one and read and go back to the main page, the one I was just in is still showing as unread. It was easier to keep track of what you’ve looked at if they would show…. not sure if this is a glitch or not…
Edit to add – the threads that I’ve posted in are showing as read but anything that I’ve just read aren’t….

Jason admin said

Yep, we noticed that one. I’ll add it to the list.

OMGsrsly said

This is weird, and of course it’s the first tea I wanted to log today. I can search the terms “berry victoria” and get nothing, but the tea is there. I can get to it other ways.

http://steepster.com/teas/silk-road/53769-berry-victoria

OMGsrsly said

To clarify, “silk road berry” doesn’t work, nor does “silk road berry victoria” but “silk road victoria” brings up 2 teas, one of which is berry victoria. IDK, I’m going to go post my tasting note!

OMGsrsly said

And we (team tea!) figured it out. “berry” flips over to “berries” when searching. So teas with “berry” in the name just don’t come up. You have to search “berr” to get teas with “berry” in the name.

LOL! That’s a new one!

OMGsrsly said

Another tea I had today! “pu-erh” and “puer” aren’t linked search terms. So “naked puer” didn’t work but “naked pu-erh” did. I mean, not THAT big of a deal, but I had noticed that a lot of search terms were linked now.

I just encountered the same problem with the word “berry” while trying to add Rich Berry Pie Matcha to my cupboard. I was finally able to pull up the correct tea by entering in “Rich Pie Matcha”.

Jason admin said

I’ve added this to the list. I’ve also got a few other examples of search working in not optimal ways, so hopefully that will be enough to figure out what’s happening. This is currently in the confirmed section of bugs.

Login or sign up to leave a comment.