Hide

Welcome to Steepster, an online tea community.

Write a tea journal, see what others are drinking and get recommendations from people you trust. or Learn More

K S said

My first kettle

I just home from Macy’s. They had a 40% off sale today only. I went looking for a kettle they had on their web site that had a thermometer built in. They did not have that one in store. Instead I picked up a Russell Hobbs tea tray. It has a 1.7 liter cordless kettle, a caraffe with good looking wire mesh infuser with a handle for easy removal, and a heating tray to keep the caraffe hot. Auto shut off on the kettle. Got it all for around $25. Googled it and I seem to have gotten a pretty good deal. I will report back after I have used it a time or two.

2 Replies
K S said

Gave the new kettle its first real workout today. My first thought is what have I done! I am beginning to wonder if the old Hot Shot had mystical powers. All my teas through it were bright and alive. Most of what I brewed today was a little flat and ho hum. I measured the amount of water for two cups, heated it, and poured it into the carafe over the same amount of tea I always use for two cups. Tried this three times and was less than impressed. The last time was the best – had a phone call and steeped about 3 times longer than normal. Tomorrow I am going to try a couple of things differently. First I am going to bypass the carafe and steep in the cup. This is the way I normally prepare my tea. If I still don’t get the full flavor I will try turning off the kettle before it comes to a full boil or wait until it cools some to pour it. Maybe the secret of the mystical powers is actually a cooler temperature. Last resort is to use more tea. Can’t come up with a reason why I should have to use more but if that is what it takes. I want my flavor back.

Login or sign up to post a message.

K S said

Secret of the mystic powers revealed! I started out today with Ahmad No. 1. This time I steeped the tea in the mug as I’ve done in the past in an attempt to eliminate the carafe as the problem. My usual steep time with this tea was observed. The tea was flat so I doubled the steep time. This made a big difference but not as full flavored as past brews. Next thought I would brew Ahmad Earl Grey green as I am most familiar with how it behaves. Increased the steep time. Close to proper taste but a bit flat and the pucker factor was a little high. Next cup, Tazo Lotus – I tried something different by bringing the water to a boil, then walked away for two minutes. Came back poured the water over the tea. Steeped my usual time and tasted. All the flavor was back.

All the teas I am currently using say to use boiling water, but by decreasing the temperature more flavor was released – even with shorter steep time. Until someone offers a better explanation I can only surmise this is the opposite of throwing steak on a really hot grill. It sears the flavor in, of course with tea we want the flavor released. This makes sense with the green teas despite what the instructions say but I haven’t figured out yet why it is proving true for my black teas as well. I guess it doesn’t matter why as long as it works.

Before starting this kettle thread, I probably lost credibility with some of you over my microwave and tea comments. There were some who agreed with me but most thought I was simply not getting the water hot enough. Now after spending some serious time with my new kettle and arriving at similar results, I wonder if just the opposite was occurring and the water was simply too hot.

My final thoughts here are when trying a new tea and finding it boring, throw out the directions and experiment with the temperature and steep time. It could be the instructions, and logic, are just wrong.

Login or sign up to post a message.

Login or sign up to leave a comment.